50 DEM disappeared (at least 2nd time I noticed this!)

As a guest you will only see a limited part of what is going on.
Register now for free and see the whole range of the eMark community!
  • Hi,


    I have an eMarkd client on a Mac Mini running. With the same wallet.dat (keys) I have the Windows Binary active.
    I am solo mining against the eMarkd.
    A script is polling the eMarkd (for networkhashrate & dem balance). Any change in the network balacen triggers some
    logic (that is independent of the eMarkd) and also logs my balace.


    Let me show you what I did observe (rounded network hashrate in Gh, newmint, balance)
    Thu Nov 7 09:15:24 2013: 1121 Gh 1000.000 + 12850.096 = 13850.096 + found a block
    Thu Nov 7 09:37:52 2013: 1039 Gh 1050.001 + 12850.096 = 13900.097 + found a block
    Thu Nov 7 09:40:23 2013: 885 Gh 1100.001 + 12850.096 = 13950.097 + found a block
    Thu Nov 7 09:41:14 2013: 931 Gh 1050.001 + 12850.096 = 13900.097
    Thu Nov 7 09:43:27 2013: 932 Gh 1050.001 + 12850.096 = 13900.097
    Thu Nov 7 09:44:58 2013: 961 Gh 1050.001 + 12850.096 = 13900.097
    (sorry for not printing blocknumbers, I will improve my script!)


    So somewhere between 9:40:23 and 09:41:14 I lost 50 DEM.
    There is no indication what happened in the Win emark-qt client.
    The DEM address used: NRcAQ3hHqtreJyH5uPGD7ZomYWWxzz7GaN


    The same problem happened with solo mining against the Win emark-qt software like a week ago.


    The Win popup showed an incoming transaction (block found) but no log-entry about any problem or the
    found block could be found using the emark-qt client.


    trepex

  • Hi Trepex,


    yes, I know it from your advice some weeks ago. The only solution I had on this, is that a Block was solved in the same time betwenn others.
    Means that your block on 9:37:52 was also submitted by another - these might solved them on 9:37:519. The system decided to sign your block as invalid,
    after the confirmations for these blocks run trough the network and deducted it from your balance. The only problem atm is the print-out function - I think
    you should get a notice when it happens. I mine at coin-base.net to support the net - it's there happened also 2 days ago.
    May you please let me know the block heights for further investigation?

  • Quote from bzzzum link


    May you please let me know the block heights for further investigation?


    I don't have it. I updated my scripts so that I have the block number the next time it will show up.


    I know that it's just a problem of a missing logging feature! But it should be fixed! Support your
    Solo-Miners, you need them!

  • And here another case - with blocknumber now:


    Time : Blocknumber @ Networkhash in Gh new minted + balace = sum + comment
    -----------------------------------------------------------------------------------------------
    Thu Nov 7 18:24:55 2013: 19471 @ 1161.29 Gh 750.004 + 14900.111 = 15650.115
    Thu Nov 7 18:46:58 2013: 19472 @ 1078.12 Gh 800.005 + 14900.111 = 15700.116 + Block found
    Thu Nov 7 18:49:14 2013: 19481 @ 1088.88 Gh 650.004 + 15000.111 = 15650.115


    I normally have one line for each block. But what happened here? I did miss 8 blocks! Or some other problem did
    show up as block 19462 took very long for my setup.


    How is this data generated?
    Ugly! I am not a programmer. But I did work doing QA/support for many years.
    I am polling the eMarkd every 6s and check if the networkhashrate did change, if it did change, I collect
    the current account ballace by using the "getinfo" command.


  • PM'ed

  • when you do solo minning then wallet must be on all the time.
    once in the beginning i have like 7 block to mine and i restart computer... after that all were lost..
    can i recovery that ? probably not...