[Solved] Cryptsy wallet down: dev help required??

  • Cryptsy administrator Mullick is having difficulties getting back up the Cryptsy DeM wallet. He indicates that it appears that commits were made around the 19th of January and that either a a repair or a roll back might be required. My roll is to transfer his message onto this forum. Could someone look into this? Thanks in advance.


    [hr]
    Re: [DeM] Deutsche eMark - DEM - cryptocoin SHA256 POS/POW
    150219 - Today at 06:40:11 AM

    eMarks current repository seems to be broken. The update to a different database should have been a mandatory update as it could cause a fork in the network. But in its current state it only seems to make our node crash every few blocks or so with the following as the last output the the debug log. This is after a fresh resync and removing all transaction data from the wallet


    Code:


    ERROR: CTxMemPool::accept() : nonstandard transaction type
    CommitTransaction() : Error: Transaction not valid
    CWalletTx::GetAmounts: Unknown transaction type found, txid fcca66178ed8088e63e35b318aabf6da50de9f973448691bfa97ca1964ebea3a


    Once either the repository is fixed or the decision to revert back to the previous version is made we will once again enable deposits and withdrawals

    Contact: mullick@cryptsy.com
    [hr]
    Original thread / message: https://bitcointalk.org/index.…939.msg10508272#msg105082

  • Tut sich hier was? Ein Info wäre hilfreich.


    Wenn Cryptsy wieder funktioniert, schiesst der Kurs sicher in den Keller, da es seit zwei Wochen nicht möglich ist, DEM nach Cryptsy zu schieben.
    Es hängen grosse Mengen bei den Minern die dann schlagartig auf den Markt geworfen werden.

  • I relayed Mullick's request to this forum in order to get attention from the right people, people who can maybe seriously help Mullick and Cryptsy. It is not a discussion about who's to blame. The Cryptsy wallet is probably the most used wallet in the DeM network and the DeM owns its value largely to Cryptsy's existence. Without Cryptsy it would be practically worthless.


    Maybe the dev (team) can write a script to check and sanitize the wallet.dat file. This could be a new feature for future releases. Or maybe they can assist Cryptsy in finding the cause of the problem. I can imagine that proper support by the DeM team leads a good impression at Cryptsy.


  • Komisch ist, daß das Wallet bei tausenden Usern läuft und bei cryptsy nicht...


    Dessen ungeachtet brauchen sie Hilfe.


    Wenn die DEM faktisch nicht mehr handelbar ist (es bleibt mW nur noch coins-e) verlieren die Leute das Interesse an der Währung.
    Ich kann leider nicht helfen. Als ich mich mit Programierung befasst habe, waren 5 MB-Festplatten der Standard.

  • Super! I'm glad as well to see there's an update!


    From Mullick's comment I can make up that Cryptsy may have been running on the 1.2.0 wallet. My only concern is that, that version was more or less meant as a test wallet or 'pre-production' version. For the future it might be a good practice to assist and advice key nodes / exchanges like (in this case) Cryptsy to prevent problems and outages, if this is not already the case. An additional toolkit to check or repair wallet, database or diagnose/monitor the connection could also be an interesting option.


    My compliments for all the efforts made.

  • Hi !


    Glen123 hier from BitcoinTalk Forum


    ich habe ja gestern mit Rumhocker telefoniert und es scheint so zu sein das ihr auf 1.1 wieder zurückgehen müsst


    Ich werde gleich nochmals die 1.1 auf meinem Pool testen und dann berichten
    Blockfind,TX usw usw


    Mal sehen ob wir die Kuh vom Eis bekommen.



    Gruss Glen


  • Now 1.2.1 its running like 1.2.0 without errors.


    Da war ich wohl etwas zu vorschnell. Leider hat Mullick recht. Es gibt wirklich Probleme mit der Version 1.2.x
    Manchmal kann keine Transaktion gesendet werden. Dieses führt wiederum zu Komplikationen mit der Wallet.dat
    Die Fehlersuche gestaltet sich schwieriger als gedacht, da ich noch nicht richtig weis wo der Fehler entsteht.
    Deswegen möchte ich Euch bitten, die Version 1.2.x nicht länger zu verwenden.
    Ich bleibe auf jeden Fall dran und hoffe bis Ende der Woche eine Lösung präsentieren zu können.


    Rumhocker

  • macht es Sinn hier Cryptsy und den Minern volle Priorität zu geben und wir nehmen alle dasselbe Wallet erstmal wieder?