Building from source Emark 1.5.1 using Ubuntu 16.04

Als Gast bekommst du nur einen geringen Teil der Geschehnisse zu sehen.
Registriere dich jetzt kostenfrei und erblicke das volle Spektrum der eMark Gemeinschaft!
  • Hi there guys,


    Please can someone help me. I am unable to build any of the wallets as my Ubuntu 16,04 system complains about BIGNUM problems. I understand that there are openssl issues, but I have tried everything. I can build other coins joule, zeta, maza, a whole lot of them. They all build ok, but I cannot rebuild this one. I already have a wallet but I upgraded to ubuntu 18.04 and thought I would build the new wallet 1.5.1. I then could not and was suggested that I downgrade ssl. I tried everything then went back to ubuntu 16.04, all other coins are building fine and work great apart from this one. Originally I have a version that I cloned from github that had a structure DEM/eMark, but I have never been able to get this to compile ever again.


    Please can someone help me out.


    Thanks to you all.


    Colin.


  • Expresszeitung.com - Jetzt abonnieren!
    Registrierte Mitglieder genießen das Forum werbefrei!
  • Hi,

    do you have time and some expirience with notepad qq? Do you want help me to fix this error?


    If someone want use openssl v1.1, you can help test it by changing some code like this:

    https://github.com/aurarad/Aur…367d1872a0a0c7f135b460af5

    If this work, i can add this to the next version of eMark-QT

    At this time i cannot change my LINUX System to 18.04 and so i cannot test the code above.

    Thanks

    Rumhocker


  • Hi there,


    I copied the whole thing and pasted this into a blank bignum.h file but now I get this, please advise,


    bignum.h:69:18: error: ISO C++ forbids declaration of ‘CBigNum_init’ with no type [-fpermissive]

    CBigNum_init()

    ^

    bignum.h: In member function ‘int CBigNum::CBigNum_init()’:

    bignum.h:72:5: warning: no return statement in function returning non-void [-Wreturn-type]

    }

    ^

    In file included from chainparams.h:9:0,

    from alert.cpp:7:

    bignum.h: In member function ‘void CBigNum::SetHex(const string&)’:

    bignum.h:485:34: error: ‘HexDigit’ was not declared in this scope

    while ((n = HexDigit(*psz)) != -1)

    ^

    makefile.unix:171: recipe for target 'obj/alert.o' failed



    Many thanks


    Colin.




    Hi there,


    Ok I tried again with notepadqq I have time on my hands but why is there no up to date source you can build this from?


    I aurora code is similar but not the same, I have tried but to no success with bulding.


    Please can you help,


    Regards


    Colin.